Ensure the host binary will be compile in 32bits mode
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 May 2007 17:30:00 +0000 (17:30 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 May 2007 17:30:00 +0000 (17:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7260 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/fortune-mod/Makefile

index d48f4d7..25084e4 100644 (file)
@@ -30,7 +30,7 @@ define Package/fortune-mod
 endef
 
 define Build/Compile
-       $(HOSTCC) -Wall -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
+       $(HOSTCC) -Wall -m32 -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
        $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/datfiles/fortunes $(PKG_BUILD_DIR)/datfiles/fortunes.dat
        $(MAKE) -C $(PKG_BUILD_DIR)/fortune
 endef