Update nrpe to 2.12 (#3639)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 11:58:17 +0000 (11:58 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2008 11:58:17 +0000 (11:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11694 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/nrpe/Makefile
net/nrpe/patches/100-openssl-dh.patch

index c355a7d..a7a756a 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nrpe
-PKG_VERSION:=2.8.1
+PKG_VERSION:=2.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
-PKG_MD5SUM:=
+PKG_MD5SUM:=b2d75e2962f1e3151ef58794d60c9e97
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,11 +27,12 @@ define Package/nrpe
 endef
 
 define Package/nrpe/description
- NOTE: several assumptions are made:
- 1) As openssl is used to generate some stuff during "configure" it is 
- assumed that openssl is installed on compiling PC in its default
- location (i.e. accessible as /usr/bin/openssl).
- 2) "nagios" user and group should exist on your openwrt installation.
+       The NRPE addon is designed to allow you to execute Nagios plugins on
+       remote Linux/Unix machines.  The main reason for doing this is to allow
+       Nagios to monitor "local" resources (like CPU load, memory usage, etc.)
+       on remote machines.  Since these public resources are not usually
+       exposed to external machines, an agent like NRPE must be installed on
+       the remote Linux/Unix machines.
 endef
 
 define Package/nrpe/postinst
index a851807..0b7f8c9 100644 (file)
@@ -1,19 +1,17 @@
-Index: nrpe-2.8.1/configure
-===================================================================
---- nrpe-2.8.1.orig/configure  2007-10-11 14:40:36.000000000 +0200
-+++ nrpe-2.8.1/configure       2007-10-11 14:40:36.000000000 +0200
-@@ -6073,11 +6073,9 @@
+--- a/configure
++++ b/configure
+@@ -6694,11 +6694,9 @@
  
-                               echo ""
-               echo "*** Generating DH Parameters for SSL/TLS ***"
--              if test -f "$ssldir/sbin/openssl"; then
--                      sslbin=$ssldir/sbin/openssl
--              else
--                      sslbin=$ssldir/bin/openssl
--              fi
-+              # Use host openssl as it just generates some random stuff,
-+              # nothing machine-specific
-+              sslbin=/usr/bin/openssl
-               # awk to strip off meta data at bottom of dhparam output
-               $sslbin dhparam -C 512 | awk '/^-----/ {exit} {print}' > include/dh.h
-       fi
+                                               echo ""
+                       echo "*** Generating DH Parameters for SSL/TLS ***"
+-                      if test -f "$ssldir/sbin/openssl"; then
+-                              sslbin=$ssldir/sbin/openssl
+-                      else
+-                              sslbin=$ssldir/bin/openssl
+-                      fi
++                      # Use host openssl as it just generates some random stuff,
++                      # nothing machine-specific
++                      sslbin=/usr/bin/openssl
+                       # awk to strip off meta data at bottom of dhparam output
+                       $sslbin dhparam -C 512 | awk '/^-----/ {exit} {print}' > include/dh.h
+               fi