added a function, that packages can call to make installing files/folders much cleane...
authorJohn Crispin <blogic@openwrt.org>
Sun, 7 Oct 2007 01:55:03 +0000 (01:55 +0000)
committerJohn Crispin <blogic@openwrt.org>
Sun, 7 Oct 2007 01:55:03 +0000 (01:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9171 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index d61eb8c..6307a1f 100644 (file)
@@ -121,6 +121,10 @@ define libtool_fixup_libdir
                $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
 endef
 
+define pkg_install_files
+       $(foreach install_file,$(2),$(INSTALL_DIR) $(1)/`dirname $(install_file)`; $(CP) $(PKG_INSTALL_DIR)/$(install_file) $(1)/`dirname $(install_file)`;)
+endef
+
 define Build/Prepare
   $(call Build/Prepare/Default,)
 endef