[PATCH] fix uclib bug in jamvm
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 May 2009 13:09:45 +0000 (13:09 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 May 2009 13:09:45 +0000 (13:09 +0000)
I just realized that tls has some problems with ulibc. This patch disables
it and uses more opewrt-style install directories for libraries.
Signed-off-by: Roberto Riggio <roberto.riggio@create-net.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15988 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/jamvm/Makefile
libs/classpath/Makefile

index bf7ae80..95b09d1 100644 (file)
@@ -36,6 +36,8 @@ define Package/jamvm/description
 endef
 
 CONFIGURE_ARGS+= \
+       --with-classpath-install-dir=/usr \
+       --disable-tls \
        --enable-ffi \
        --disable-int-threading \
 
index 3941f0a..e7561b0 100644 (file)
@@ -45,10 +45,10 @@ define Build/Compile
 endef
 
 define Package/classpath/install
-       $(INSTALL_DIR) $(1)/usr/local/classpath/share/classpath/
-       $(INSTALL_DIR) $(1)/usr/local/classpath/lib/classpath/
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/glibj.zip $(1)/usr/local/classpath/share/classpath/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/classpath/* $(1)/usr/local/classpath/lib/classpath/
+       $(INSTALL_DIR) $(1)/usr/share/classpath
+       $(INSTALL_DIR) $(1)/usr/lib/classpath
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/glibj.zip $(1)/usr/share/classpath/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/classpath/* $(1)/usr/lib/classpath/
 endef
 
 $(eval $(call BuildPackage,classpath))