Successfully exit from the postinst script if the /etc/services entry already exists...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2008 09:32:28 +0000 (09:32 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2008 09:32:28 +0000 (09:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10568 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openntpd/Makefile

index 1629957..ba7e847 100644 (file)
@@ -73,7 +73,7 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
 fi
 
 grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services
+[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services || exit 0
 endef
 
 define Build/Configure