rework 330-remove_m64_switch patch to be less intrusive, thanks nbd
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 3 Feb 2009 14:19:25 +0000 (14:19 +0000)
committerJiri Slachta <slachta@cesnet.cz>
Sat, 8 Mar 2014 11:08:04 +0000 (12:08 +0100)
libs/zaptel-1.4.x/patches/330-remove_m64_switch.patch [deleted file]
libs/zaptel-1.4.x/patches/330-uname_m.patch [new file with mode: 0644]

diff --git a/libs/zaptel-1.4.x/patches/330-remove_m64_switch.patch b/libs/zaptel-1.4.x/patches/330-remove_m64_switch.patch
deleted file mode 100644 (file)
index b2c5b24..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -urN zaptel-1.4.9.2/Makefile zaptel-1.4.9.2.new/Makefile
---- zaptel-1.4.9.2/Makefile    2008-02-22 01:31:47.000000000 +0100
-+++ zaptel-1.4.9.2.new/Makefile        2009-02-03 14:24:25.000000000 +0100
-@@ -135,9 +135,6 @@
- ifneq (,$(findstring ppc,$(UNAME_M)))
- CFLAGS_PPC:=-fsigned-char
- endif
--ifneq (,$(findstring x86_64,$(UNAME_M)))
--CFLAGS_x86_64:=-m64
--endif
- CFLAGS+=$(CFLAGS_PPC) $(CFLAGS_x86_64)
- KFLAGS=-I$(KINCLUDES) -O6
- KFLAGS+=-DMODULE -D__KERNEL__ -DEXPORT_SYMTAB -I$(KSRC)/drivers/net \
diff --git a/libs/zaptel-1.4.x/patches/330-uname_m.patch b/libs/zaptel-1.4.x/patches/330-uname_m.patch
new file mode 100644 (file)
index 0000000..cf25934
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN zaptel-1.4.9.2/Makefile zaptel-1.4.9.2.new/Makefile
+--- zaptel-1.4.9.2/Makefile    2008-02-22 01:31:47.000000000 +0100
++++ zaptel-1.4.9.2.new/Makefile        2009-02-03 15:24:16.000000000 +0100
+@@ -21,7 +21,7 @@
+ ARCH:=$(shell uname -m | sed -e s/i.86/i386/)
+ ifeq ($(DEB_HOST_GNU_TYPE),)
+-UNAME_M:=$(shell uname -m)
++UNAME_M:=$(ARCH)
+ else
+ UNAME_M:=$(DEB_HOST_GNU_TYPE)
+ endif