[packages] distribute: install host modules in hostpython search path
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Oct 2011 14:21:09 +0000 (14:21 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Oct 2011 14:21:09 +0000 (14:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28402 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/distribute/Makefile

index f11f6cb..f164508 100644 (file)
@@ -41,10 +41,10 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)$(PYTHON_PKG_DIR)
+       $(INSTALL_DIR) $(STAGING_DIR)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(STAGING_DIR_HOST)$(PYTHON_PKG_DIR)
+           $(STAGING_DIR)$(PYTHON_PKG_DIR)/
 endef
 
 define Build/Compile
@@ -55,7 +55,7 @@ define Package/distribute/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+           $(1)$(PYTHON_PKG_DIR)/
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
            $(PKG_INSTALL_DIR)/usr/bin/easy_install \