[packages] freecwmp: update to the latest version
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Sep 2012 17:35:39 +0000 (17:35 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Sep 2012 17:35:39 +0000 (17:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33553 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/freecwmp/Makefile

index dd60c78..6b70fa4 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freecwmp
-PKG_VERSION:=2012-08-02
+PKG_VERSION:=2012-09-25
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://dev.freecwmp.org/freecwmp
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=e5b23acadfd06e6ea9fac40e0bf9975fe25ee1e5
+PKG_SOURCE_VERSION:=4bfbd994921dee06a7a28bed1f2dee3d527490f4
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_FIXUP:=autoreconf
@@ -33,7 +33,7 @@ define Package/freecwmp/Default
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=CWMP client
-  DEPENDS:=+libuci +libubox +libubus +libmicroxml +shflags
+  DEPENDS:=+libfreecwmp +libuci +libubox +libubus +libmicroxml +shflags
 endef
 
 define Package/freecwmp/description
@@ -72,6 +72,7 @@ TARGET_LDFLAGS += \
        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 
 CONFIGURE_ARGS += \
+       --with-libfreecwmp-include-path=$(STAGING_DIR)/usr/include \
        --with-uci-include-path=$(STAGING_DIR)/usr/include \
        --with-libubox-include-path=$(STAGING_DIR)/usr/include \
        --with-libubus-include-path=$(STAGING_DIR)/usr/include
@@ -104,7 +105,7 @@ endif
 
 ifeq ($(CONFIG_FREECWMP_DEVEL_DEBUG),y)
 CONFIGURE_ARGS += \
-       --enable-devel-debug
+       --enable-devel
 endif
 
 define Package/freecwmp-$(BUILD_VARIANT)/conffiles