mgen: replace uclibc++ hacks with g++-uc wrapper
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jun 2012 16:17:08 +0000 (16:17 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jun 2012 16:17:08 +0000 (16:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32355 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/mgen/Makefile

index 38a7961..1e7e30f 100644 (file)
@@ -37,8 +37,8 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/unix \
-               CC="$(TARGET_CXX)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++"  \
+               CC="g++-uc" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)"  \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                SYSTEM_LIBS="-ldl -lpthread -luClibc++" \
                -f Makefile.linux mgen