[package] keepalived: fix compile
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Nov 2013 17:09:09 +0000 (17:09 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Nov 2013 17:09:09 +0000 (17:09 +0000)
newer kernels (3.7) split user side headers

should fix: #12875

Should the patch be compatible with older kernels too?
(see https://dev.openwrt.org/ticket/12875#comment:6 )

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@38841 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/keepalived/Makefile

index d7396b2..b7ac46a 100644 (file)
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+= \
        --disable-strip \
        --disable-lvs \
        --disable-lvs-syncd \
-       --with-kernel-dir="$(LINUX_DIR)"
+       --with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)"
 
 CONFIGURE_VARS+= \
        ac_cv_file_$(call acvar,$(LINUX_DIR)/net/core/link_watch.c)=yes