[PATCH] Update and FIX socat
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Apr 2011 19:14:02 +0000 (19:14 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Apr 2011 19:14:02 +0000 (19:14 +0000)
socat was bugged for ages now. It does compile, so probably no one
noticed. While running through its configure script, the build process
complains about some missing variables and gives a hint, that the user
should supply them manually. This does ONLY happen in a cross compiling
environment, otherwise the configure script guesses them right. I don't
know the purpose of these variables exactly, but they seem to be OS
dependent and NOT hardware dependent. I tested this on various
architectures and they were all the same, as long as linux is involved.
So I think its safe to specify them in the Makefile.

The point why they're important, is simply that socat compiles, but
exits with some sort of error right after invocation, if they weren't
present at compile time. There are numerous tickets around concerning
this bug. Newer Versions of socat won't even compile if they're missing,
maybe thats why it's kinda outdated by now.

However, this little patch should fix it.

Signed-off-by: Hendrik Bartusch <bartusch@exoz.net>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26728 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/socat/Makefile

index 43a595b..009da5e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=socat
-PKG_VERSION:=1.6.0.1
+PKG_VERSION:=1.7.1.3
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download/
-PKG_MD5SUM:=6a0dd33cde2a18eb382433aca8f76ce2
+PKG_MD5SUM:=2081987fb0cb0290b8105574058cb329
 
 PKG_INSTALL:=1
 
@@ -44,6 +44,9 @@ define Build/Configure
                --enable-termios \
                , \
                sc_cv_termios_ispeed="no" \
+               sc_cv_sys_crdly_shift=9 \
+               sc_cv_sys_tabdly_shift=11 \
+               sc_cv_sys_csize_shift=4 \
        )
 endef