Fix matchbox linking.
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Nov 2008 23:15:20 +0000 (23:15 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Nov 2008 23:15:20 +0000 (23:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13438 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/app/matchbox/Makefile

index d08a8ed..e00b043 100644 (file)
@@ -17,13 +17,16 @@ PKG_SOURCE_URL:=http://matchbox-project.org/sources/matchbox-window-manager/$(PK
 
 PKG_FIXUP = libtool
 
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/matchbox
   TITLE:=matchbox window manager
   SECTION:=xorg-wm
   CATEGORY:=Xorg
-  DEPENDS:=+libX11 +zlib +libfreetype +fontconfig +libmatchbox @DISPLAY_SUPPORT
+  DEPENDS:=+libX11 +zlib +libfreetype +fontconfig +libmatchbox
 endef
 
 define Build/Compile