mpd will now let alsa be enabled if the soundcore kmod is present
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Jul 2007 19:30:39 +0000 (19:30 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Jul 2007 19:30:39 +0000 (19:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8221 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mpd/Makefile

index 6dee118..51b716f 100644 (file)
@@ -38,9 +38,13 @@ define Package/mpd/conffiles
 /etc/mpd.conf
 endef
 
+ifndef CONFIG_PACKAGE_kmod-soundcore
+       EXTRA_CONFIG_PARAM:=--disable-alsa
+endif
+
 define Build/Configure
        $(call Build/Configure/Default, \
-               --disable-alsa \
+               $(EXTRA_CONFIG_PARAM) \
                --disable-shout \
                --disable-mod \
                --disable-audiofile \