Create /etc/services for ntp if not existing(#1557)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Apr 2007 20:35:36 +0000 (20:35 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Apr 2007 20:35:36 +0000 (20:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6903 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ntpd/Makefile

index 4607546..498d695 100644 (file)
@@ -35,6 +35,12 @@ define Package/ntpd/conffiles
 /etc/ntp.conf
 endef
 
+define Package/ntpd/postinst
+#!/bin/sh
+echo "ntp             123/udp     # Network Time Protocol
+ntp             123/tcp     # Network Time Protocol" >> /etc/services
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                 --disable-all-clocks \