[packages] strongswan4: add missing dependencies, depend on libmysqlclient-r instead...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Jun 2012 22:44:53 +0000 (22:44 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Jun 2012 22:44:53 +0000 (22:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32275 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/strongswan4/Makefile

index 3044020..cb7f522 100644 (file)
@@ -70,10 +70,6 @@ PKG_MOD_AVAILABLE:= \
        xauth \
        xcbc \
 
-PKG_BUILD_DEPENDS:= \
-       PACKAGE_strongswan4-libfast:clearsilver \
-       PACKAGE_strongswan4-libfast:fcgi \
-
 PKG_CONFIG_DEPENDS:= \
        CONFIG_STRONGSWAN4_ENABLE_CISCO_QUIRKS \
        CONFIG_STRONGSWAN4_ENABLE_NAT_TRANSPORT \
@@ -293,7 +289,7 @@ endef
 define Package/strongswan4-libfast
 $(call Package/strongswan4/Default)
   TITLE+= libfast
-  DEPENDS:= +strongswan4
+  DEPENDS:= +strongswan4 +PACKAGE_strongswan4-libfast:zlib +PACKAGE_strongswan4-libfast:fcgi
 endef
 
 define Package/strongswan4-libfast/description
@@ -474,7 +470,7 @@ $(eval $(call BuildPlugin,load-tester,load testing,))
 $(eval $(call BuildPlugin,md5,MD5 crypto,))
 $(eval $(call BuildPlugin,medcli,mediation client configuration database,))
 $(eval $(call BuildPlugin,medsrv,mediation server configuration database,))
-$(eval $(call BuildPlugin,mysql,MySQL database interface,+strongswan4-mod-sql +PACKAGE_strongswan4-mod-mysql:libmysqlclient))
+$(eval $(call BuildPlugin,mysql,MySQL database interface,+strongswan4-mod-sql +PACKAGE_strongswan4-mod-mysql:libmysqlclient-r))
 $(eval $(call BuildPlugin,padlock,VIA PadLock crypto,@TARGET_x86))
 $(eval $(call BuildPlugin,pem,PEM decoding,))
 $(eval $(call BuildPlugin,pgp,PGP key decoding,))