packages/rp-l2tp: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:15:26 +0000 (22:15 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:15:26 +0000 (22:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29049 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/rp-l2tp/Makefile
net/rp-l2tp/files/rp-l2tpd.init

index d120c34..61e9cce 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-l2tp
 PKG_VERSION:=0.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rp-l2tp
index 4895e17..cff1f15 100644 (file)
@@ -1,17 +1,13 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=60
-DEFAULT=/etc/default/rp-l2tpd
-RUN_D=/var/run
-[ -f $DEFAULT ] && . $DEFAULT
 
 start() {
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       l2tpd $OPTIONS
+       service_start /usr/sbin/l2tpd
 }
 
 stop() {
-       killall l2tpd
+       service_stop /usr/sbin/l2tpd
 }