boblight: forcibly build against libstdc++
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jan 2013 19:41:39 +0000 (19:41 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jan 2013 19:41:39 +0000 (19:41 +0000)
The uClibc++ implementation of stringstream operator>> is broken which
fails boblightd at runtime when parsing the configuration.

Due to the failed parsing, std::list unique() is called with an empty
list which causes the program to trigger a segmentation fault, this
is most likely another uClibc++ implementation error.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@35027 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/boblight/Makefile

index 0b53370..410a132 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011-2012 OpenWrt.org
+# Copyright (C) 2011-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=boblight
 PKG_REV:=412
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://boblight.googlecode.com/svn/trunk
@@ -20,7 +20,6 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
 
 PKG_INSTALL:=1
 
-include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/boblight/Default
@@ -28,7 +27,7 @@ define Package/boblight/Default
   CATEGORY:=Utilities
   TITLE:=Tools for driving lights connected to an external controller
   URL:=http://code.google.com/p/boblight/
-  DEPENDS:=+librt $(CXX_DEPENDS)
+  DEPENDS:=+librt +libstdcpp
 endef
 
 define Package/boblight/Default/description