[packages] xkeyboard-config: misc fixes:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Aug 2010 17:06:20 +0000 (17:06 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Aug 2010 17:06:20 +0000 (17:06 +0000)
 * add MD5SUM
 * remove unneeded Build/Configure override
 * fix indent in Package/.../install
 * check for host intltool

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22459 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/xorg/data/xkeyboard-config/Makefile

index be355b7..dbbc14c 100644 (file)
@@ -13,8 +13,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://xlibs.freedesktop.org/xkbdesc/
-PKG_INSTALL:=1
+PKG_MD5SUM:=d351c0109fac166edcedad32d1b0e38e
 
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,13 +27,13 @@ define Package/xkeyboard-config
   URL:=http://freedesktop.org/wiki/Software/XKeyboardConfig
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default)
-endef
 define Package/xkeyboard-config/install
-  $(INSTALL_DIR) $(1)/usr/share/X11/xkb
-    $(CP) -v $(PKG_INSTALL_DIR)/usr/share/X11/xkb \
-      $(1)/usr/share/X11/
+       $(INSTALL_DIR) $(1)/usr/share/X11
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/X11/xkb $(1)/usr/share/X11/
 endef
 
+$(eval $(call RequireCommand,intltool-update, \
+       $(PKG_NAME) requires intltool installed on the host-system. \
+))
+
 $(eval $(call BuildPackage,xkeyboard-config))