zsh: disable checking for NIS and NIS+
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:58:09 +0000 (00:58 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:58:09 +0000 (00:58 +0000)
Those might be installed on the host, but certainly not available for the
target, disable checking for those.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39837 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/zsh/Makefile

index c6d37bd..79c0daa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zsh
 PKG_VERSION:=5.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/zsh
@@ -41,7 +41,9 @@ define Build/Configure
                --bindir=/bin \
                --disable-etcdir \
                --disable-gdbm \
-               --with-term-lib="ncurses" \
+               --with-term-lib="ncurses", \
+               zsh_cv_sys_nis=no \
+               zsh_cv_sys_nis_plus=no \
        )
        # Do not install these functions:
        $(SED) 's, Completion/AIX/\*/\*,,g' $(PKG_BUILD_DIR)/config.modules