[packages] gsl: install pkgconfig gsl.pc, thanks Xiangfu Liu
authorswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 14:53:28 +0000 (14:53 +0000)
committerswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 14:53:28 +0000 (14:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27645 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gsl/Makefile

index c9c5e19..62eaaae 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -43,10 +43,11 @@ define Package/libgsl/install
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/gsl $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include/gsl $(1)/usr/lib $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gsl/*.h $(1)/usr/include/gsl
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgsl.* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgslcblas.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gsl.pc $(1)/usr/lib/pkgconfig/
 endef
 
 $(eval $(call BuildPackage,libgsl))