[packages] remove usages of $(CONFIG_LARGEFILE) and $(DISABLE_LARGEFILE)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jan 2011 16:59:47 +0000 (16:59 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jan 2011 16:59:47 +0000 (16:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25207 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/dibbler/Makefile
libs/db47/Makefile
libs/ossp-js/Makefile
libs/postgresql/Makefile
libs/rrdtool-1.0.x/Makefile
net/elinks/Makefile
net/lighttpd/Makefile
net/openssh/Makefile
net/samba/Makefile
net/samba3/Makefile

index 419f8ef..6a2a443 100644 (file)
@@ -101,7 +101,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
        );
 endef
 
index c309e06..7c38f23 100644 (file)
@@ -60,7 +60,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
                        --enable-shared \
                        --enable-static \
                        --disable-java \
index 5af55f6..78ddb79 100644 (file)
@@ -69,7 +69,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
                        --disable-shared \
                        --enable-static \
        );
index 7f15de9..2120155 100644 (file)
@@ -77,7 +77,6 @@ define Build/Configure
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc \
                        $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
                        --enable-shared \
                        --enable-static \
                        --disable-integer-datetimes \
index c14fcb5..4e0eebc 100644 (file)
@@ -85,7 +85,6 @@ endef
 TARGET_CFLAGS += $(FPIC) --std=c99
 
 CONFIGURE_ARGS += \
-       $(DISABLE_LARGEFILE) \
        $(DISABLE_NLS) \
        --enable-shared=yes \
        --enable-static=yes \
index db2970c..caaefea 100644 (file)
@@ -60,7 +60,6 @@ define Build/Configure
                         --mandir=/usr/share/man \
                         --sbindir=/usr/sbin \
                         --sysconfdir=/etc \
-                        $(DISABLE_LARGEFILE) \
                         $(DISABLE_NLS) \
                         --enable-small\
                         --enable-256-colors\
index cd5ffbd..9b344cc 100644 (file)
@@ -229,11 +229,6 @@ CONFIGURE_ARGS+= \
 CONFIGURE_VARS+= \
        PCRE_LIB="-lpcre" \
 
-ifneq ($(CONFIG_LARGEFILE),y)
-  CONFIGURE_ARGS+= \
-       --disable-lfs
-endif
-
 ifeq ($(CONFIG_IPV6),y)
   CONFIGURE_ARGS+= \
        --enable-ipv6
index 8a3ee69..beb16c9 100644 (file)
@@ -110,7 +110,6 @@ OpenSSH SFTP server.
 endef
 
 CONFIGURE_ARGS+= \
-       $(DISABLE_LARGEFILE) \
        $(DISABLE_NLS) \
        --sysconfdir=/etc/ssh \
        --enable-shared \
index 7f2dd04..1fc09cf 100644 (file)
@@ -73,7 +73,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -144,7 +143,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
index dfdcb19..3ff3ec5 100644 (file)
@@ -40,11 +40,9 @@ define Package/samba3/config
        source "$(SOURCE)/Config.in"
 endef
 
-ifneq ($(CONFIG_LARGEFILE),)
-  define Build/Prepare/LFS
+define Build/Prepare/LFS
        cat ./files/config-lfs.h >> $(PKG_BUILD_DIR)/source/include/config.h
-  endef
-endif
+endef
 
 define Build/Prepare
 $(call Build/Prepare/Default)