[package] revert r18554, until we fix curl compilation on all platforms
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Dec 2009 13:52:19 +0000 (13:52 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Dec 2009 13:52:19 +0000 (13:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18659 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/curl/Makefile
libs/curl/patches/100-cross_compile.patch [new file with mode: 0644]
libs/curl/patches/510-no_sslv2.patch

index 35c47ed..128f8c6 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.19.7
+PKG_VERSION:=7.19.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=79a8fbb2eed5464b97bdf94bee109380
+PKG_MD5SUM:=8402c1f654c51ad7287aad57c3aa79be
 
 PKG_FIXUP = libtool
 
diff --git a/libs/curl/patches/100-cross_compile.patch b/libs/curl/patches/100-cross_compile.patch
new file mode 100644 (file)
index 0000000..a135d1c
--- /dev/null
@@ -0,0 +1,82 @@
+--- a/configure
++++ b/configure
+@@ -25479,16 +25479,6 @@ fi
+ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+   fi
+-  if test "$OPENSSL_ENABLED" = "1"; then
+-    if test -n "$LIB_OPENSSL"; then
+-
+-       LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
+-       export LD_LIBRARY_PATH
+-       { $as_echo "$as_me:$LINENO: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&5
+-$as_echo "$as_me: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&6;}
+-    fi
+-  fi
+-
+ fi
+@@ -26486,19 +26476,6 @@ else
+ fi
+-      if test "x$USE_GNUTLS" = "xyes"; then
+-        { $as_echo "$as_me:$LINENO: detected GnuTLS version $version" >&5
+-$as_echo "$as_me: detected GnuTLS version $version" >&6;}
+-
+-        if test -n "$gtlslib"; then
+-
+-          LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
+-          export LD_LIBRARY_PATH
+-          { $as_echo "$as_me:$LINENO: Added $gtlslib to LD_LIBRARY_PATH" >&5
+-$as_echo "$as_me: Added $gtlslib to LD_LIBRARY_PATH" >&6;}
+-        fi
+-      fi
+-
+     fi
+   fi
+--- a/configure.ac
++++ b/configure.ac
+@@ -1332,18 +1332,6 @@ if test X"$OPT_SSL" != Xno; then
+     ])
+   fi
+-  if test "$OPENSSL_ENABLED" = "1"; then
+-    if test -n "$LIB_OPENSSL"; then
+-       dnl when the ssl shared libs were found in a path that the run-time
+-       dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
+-       dnl to prevent further configure tests to fail due to this
+-
+-       LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
+-       export LD_LIBRARY_PATH
+-       AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
+-    fi
+-  fi
+-
+ fi
+ dnl **********************************************************************
+@@ -1617,21 +1605,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
+          CPPFLAGS="$CLEANCPPFLAGS"
+        ])
+-      if test "x$USE_GNUTLS" = "xyes"; then
+-        AC_MSG_NOTICE([detected GnuTLS version $version])
+-
+-        if test -n "$gtlslib"; then
+-          dnl when shared libs were found in a path that the run-time
+-          dnl linker doesn't search through, we need to add it to
+-          dnl LD_LIBRARY_PATH to prevent further configure tests to fail
+-          dnl due to this
+-
+-          LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
+-          export LD_LIBRARY_PATH
+-          AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
+-        fi
+-      fi
+-
+     fi
+   fi dnl GNUTLS not disabled
index 65b9fe3..9c1089b 100644 (file)
@@ -1,18 +1,18 @@
 --- a/lib/ssluse.c
 +++ b/lib/ssluse.c
-@@ -1397,10 +1397,12 @@
+@@ -1384,10 +1384,12 @@ ossl_connect_step1(struct connectdata *c
+   case CURL_SSLVERSION_TLSv1:
      req_method = TLSv1_client_method();
-     use_sni(TRUE);
      break;
 +#ifndef OPENSSL_NO_SSL2
    case CURL_SSLVERSION_SSLv2:
      req_method = SSLv2_client_method();
-     use_sni(FALSE);
+     sni = FALSE;
      break;
 +#endif
    case CURL_SSLVERSION_SSLv3:
      req_method = SSLv3_client_method();
-     use_sni(FALSE);
+     sni = FALSE;
 --- a/src/main.c
 +++ b/src/main.c
 @@ -824,7 +824,9 @@ static void help(void)