net-snmp: don't hardcode endianness
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Mar 2013 14:16:52 +0000 (14:16 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Mar 2013 14:16:52 +0000 (14:16 +0000)
instead of using 'little' hardcoded, rely on the config

I recommend to backport this fix to AA, once this bug
prevents MD5 authentication in protocol v3.

Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35956 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/net-snmp/Makefile

index f19d68b..551180a 100644 (file)
@@ -155,7 +155,7 @@ CONFIGURE_ARGS += \
        --enable-mfd-rewrites \
        --enable-shared \
        --enable-static \
-       --with-endianness=little \
+       --with-endianness=$(if $(CONFIG_BIG_ENDIAN),big,little) \
        --with-logfile=/var/log/snmpd.log \
        --with-persistent-directory=/usr/lib/snmp/ \
        --with-default-snmp-version=1 \