net/iputils: fix ping & arping under brcm47xx.
authoracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Mar 2011 20:02:00 +0000 (20:02 +0000)
committeracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Mar 2011 20:02:00 +0000 (20:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26278 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/iputils/Makefile

index fdf0d2d..8039bf5 100644 (file)
@@ -121,6 +121,9 @@ define Package/iputils-traceroute6/description
   Traces path to a network host (IPv6).
 endef
 
+ifeq ($(BOARD),brcm47xx)
+  TARGET_CFLAGS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall
+endif
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)" \