[packages] ulogd: compile with --export-dynamic to solve segfault in dlopen() (#8481)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 May 2011 12:21:47 +0000 (12:21 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 May 2011 12:21:47 +0000 (12:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26853 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ulogd/Makefile

index c1dc32b..ddfdc1c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -109,6 +109,7 @@ define Build/Compile
                        -I$(PKG_BUILD_DIR)/include/ulogd \
                        -I$(PKG_BUILD_DIR)/include \
                        -I$(PKG_BUILD_DIR)/libipulog/include \
+                       -Wl,--export-dynamic \
                        $(TARGET_CPPFLAGS)" \
                all install
 endef