packages/linuxigd: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:16:09 +0000 (22:16 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:16:09 +0000 (22:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29070 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/linuxigd/Makefile
net/linuxigd/files/upnpd.init

index 745a7f4..97579a8 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 # Copyright (C) 2006 loswillios
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linuxigd
 PKG_VERSION:=1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-igd
index e250305..832768f 100644 (file)
@@ -1,29 +1,25 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 # Copyright (C) 2006 loswillios
+
 START=65
 
 include /lib/network
-scan_interfaces
-config_get WAN wan ifname
-config_get LAN lan ifname
 
 start() {
-    echo -n "Starting UPnP: "
-    route add -net 239.0.0.0 netmask 255.0.0.0 $LAN
-    upnpd $WAN $LAN
-    echo "OK"
+       scan_interfaces
+       config_get wan_if 'wan' 'ifname'
+       config_get lan_if 'lan' 'ifname'
+       [ -n "$wan_if" ] || return 1
+
+       [ -n "$lan_if" ] && route add -net 239.0.0.0 netmask 255.0.0.0 $lan_if
+       service_start /usr/sbin/upnpd $wan_if $lan_if
 }
 
 stop() {
-    echo -n "Stopping UPnP: "
-    route del -net 239.0.0.0 netmask 255.0.0.0 $LAN
-    killall upnpd
-    echo "OK"
-}
+       scan_interfaces
+       config_get lan_if 'lan' 'ifname'
 
-restart() {
-        stop
-        sleep 5
-        start
+       service_stop /usr/sbin/upnpd
+       [ -n "$lan_if" ] && route del -net 239.0.0.0 netmask 255.0.0.0 $lan_if
 }