upgrade baresip, restund, libre, librem to version 0.4.1
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 18 Jun 2012 23:50:30 +0000 (23:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 29 Jan 2014 13:52:22 +0000 (13:52 +0000)
Hi,

this patch upgrades the following packages to v0.4.1:

   baresip v0.4.1 (Portable and modular SIP User-Agent with audio and video support)
   restund v0.4.1 (Modular STUN/TURN server)
   libre   v0.4.1 (Generic library for real-time communications with async IO support)
   librem  v0.4.1 (Audio and video processing media library)

detailed changes can be found in <package>/docs/ChangeLog
(See http://www.creytiv.com/)

Please review and apply if OK.

Signed-Off-By: Alfred E. Heggestad <aeh@db.org>
libs/rem/Makefile

index c145912..0e86b09 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rem
-PKG_VERSION:=0.4.0
+PKG_VERSION:=0.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub
-PKG_MD5SUM:=0d5cf133a62d11a2f80875a8fa7adab6
+PKG_MD5SUM:=bfac8837974e911bd4d4017a8f1ce39b
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -53,6 +53,7 @@ define Build/InstallDev
 endef
 
 define Package/librem/install
+       rm -f $(BUILD_DIR)/$(PKG_NAME)
        ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/librem.so $(1)/usr/lib/