[packages] apr: ditch shipped libtool, make it non-silent
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 May 2011 14:40:50 +0000 (14:40 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 May 2011 14:40:50 +0000 (14:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26831 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/apr/Makefile
libs/apr/patches/001-autoconf-compat.patch

index 94bfd99..4a0b704 100644 (file)
@@ -15,7 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.ibiblio.org/pub/mirrors/apache/apr
 PKG_MD5SUM:=4b00e8f70c067893d075577962656b35
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=aclocal.m4 build/ltmain.sh
 
 PKG_INSTALL:=1
 
index 0f383eb..88f71fd 100644 (file)
@@ -8,3 +8,15 @@
  
  #
  # APR (Apache Portable Runtime) library Makefile.
+--- a/configure.in
++++ b/configure.in
+@@ -180,9 +180,6 @@ case $host in
+     gcc $CFLAGS $CPPFLAGS -o $LIBTOOL.exe $LIBTOOL.c
+     ;;
+ *)
+-    if test "x$LTFLAGS" = "x"; then
+-        LTFLAGS='--silent'
+-    fi
+     if test "$experimental_libtool" = "yes"; then
+         # Use a custom-made libtool replacement
+         echo "using jlibtool"