pcre: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jun 2014 17:11:07 +0000 (17:11 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jun 2014 17:11:07 +0000 (17:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41429 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/pcre/Makefile [deleted file]
libs/pcre/patches/750-pcre_config_cross.patch [deleted file]

diff --git a/libs/pcre/Makefile b/libs/pcre/Makefile
deleted file mode 100644 (file)
index a7ca6d0..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-#
-# Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pcre
-PKG_VERSION:=8.11
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/pcre
-PKG_MD5SUM:=ef907b8792ec7f90f0dcd773848f0b3b
-
-PKG_LICENSE:=BSD-3c
-PKG_LICENSE_FILES:=LICENCE
-
-PKG_FIXUP:=autoreconf
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libpcre/default
-  SECTION:=libs
-  CATEGORY:=Libraries
-  URL:=http://www.pcre.org/
-endef
-
-define Package/libpcre
-  $(call Package/libpcre/default)
-  TITLE:=A Perl Compatible Regular Expression library
-endef
-
-define Package/libpcrecpp
-  $(call Package/libpcre/default)
-  TITLE:=C++ wrapper for Perl Compatible Regular Expression library
-  DEPENDS:=+libpcre +libstdcpp
-endef
-
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --enable-utf8 \
-       --enable-unicode-properties \
-
-ifneq ($(CONFIG_PACKAGE_libpcrecpp),)
-  CONFIGURE_ARGS+= --enable-cpp
-else
-  CONFIGURE_ARGS+= --disable-cpp
-endif
-
-MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS)"
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pcre-config $(1)/usr/bin/
-
-       $(INSTALL_DIR) $(2)/bin
-       $(LN) $(STAGING_DIR)/usr/bin/pcre-config $(2)/bin
-
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/pcre*.h $(1)/usr/include/
-
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre*.{a,so*} $(1)/usr/lib//
-
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpcre*.pc $(1)/usr/lib/pkgconfig/
-
-endef
-
-define Package/libpcre/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.so.* $(1)/usr/lib/
-endef
-
-define Package/libpcrecpp/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcrecpp.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libpcre))
-$(eval $(call BuildPackage,libpcrecpp))
diff --git a/libs/pcre/patches/750-pcre_config_cross.patch b/libs/pcre/patches/750-pcre_config_cross.patch
deleted file mode 100644 (file)
index 1a5ab00..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/pcre-config.in
-+++ b/pcre-config.in
-@@ -24,6 +24,10 @@ case `uname -s` in
-   libR=" -Wl,-R@libdir@"
-   ;;
- esac
-+libS=
-+if test @libdir@ != /usr/lib ; then
-+  libS=-L@libdir@
-+fi
- while test $# -gt 0; do
-   case "$1" in
-@@ -58,10 +62,10 @@ while test $# -gt 0; do
-       echo $includes @PCRE_STATIC_CFLAG@
-       ;;
-     --libs-posix)
--      echo -L@libdir@$libR -lpcreposix -lpcre
-+      echo $libS$libR -lpcreposix -lpcre
-       ;;
-     --libs)
--      echo -L@libdir@$libR -lpcre
-+      echo $libS$libR -lpcre
-       ;;
-     --libs-cpp)
-       if test @enable_cpp@ = yes ; then