contrib/meshwizard: Use the new interfaces syntax instead of the old alias syntax...
authorManuel Munz <freifunk@somakoma.de>
Tue, 29 Jan 2013 22:32:03 +0000 (22:32 +0000)
committerManuel Munz <freifunk@somakoma.de>
Tue, 29 Jan 2013 22:32:03 +0000 (22:32 +0000)
contrib/package/meshwizard/Makefile
contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_network.sh

index 3aaddec..91979b7 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=meshwizard
-PKG_RELEASE:=0.0.8-3
+PKG_RELEASE:=0.0.9-1
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 325475f..70f82fe 100755 (executable)
@@ -58,7 +58,7 @@ if [ "$net_dhcp" == 1 ]; then
                        fi
        }
        config_load network
-       config_foreach handle_dhcpalias alias
+       config_foreach handle_dhcpalias interface
 
        # Get IP/netmask and start-ip for $net dhcp
        # If no dhcprange is given in /etc/config/meshwizard we autogenerate one
@@ -69,15 +69,15 @@ if [ "$net_dhcp" == 1 ]; then
        fi
        eval $(sh $dir/helpers/ipcalc-cidr.sh $dhcprange 1 0)
 
-       # setup wifi-dhcp interface or alias
+       # setup wifi-dhcp interface or alias (using interface notation)
 
        # Setup alias for $net
 
        if [ "$vap" == 1 ]; then
                uci set network.${netrenamed}dhcp=interface
        else
-               uci set network.${netrenamed}dhcp=alias
-               uci set network.${netrenamed}dhcp.interface="$netrenamed"
+               uci set network.${netrenamed}dhcp=interface
+               uci set network.${netrenamed}dhcp.ifname="@${netrenamed}"
        fi
 
        uci batch <<- EOF
@@ -86,5 +86,4 @@ if [ "$net_dhcp" == 1 ]; then
                set network.${netrenamed}dhcp.netmask="$NETMASK"
        EOF
        uci_commitverbose  "Setup interface for ${netrenamed}dhcp" network
-
 fi