build: ensure that package/host-build build system code does not run in parallel...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 17 Sep 2012 11:17:26 +0000 (11:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 17 Sep 2012 11:17:26 +0000 (11:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33445 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk
include/package.mk

index 06f93a1..e011c15 100644 (file)
@@ -136,6 +136,8 @@ define Host/Exports/Default
 endef
 Host/Exports=$(Host/Exports/Default)
 
+.NOTPARALLEL:
+
 ifndef DUMP
   define HostBuild
   $(if $(HOST_QUILT),$(Host/Quilt))
index e93aebf..3ec5ffd 100644 (file)
@@ -248,6 +248,8 @@ Build/Install=$(if $(PKG_INSTALL),$(call Build/Install/Default,))
 Build/Dist=$(call Build/Dist/Default,)
 Build/DistCheck=$(call Build/DistCheck/Default,)
 
+.NOTPARALLEL:
+
 $(PACKAGE_DIR):
        mkdir -p $@