asterisk-1.8.x: fix configure warnings
authorDirk Neukirchen <dirkneukirchen@web.de>
Sat, 4 Jan 2014 11:51:46 +0000 (11:51 +0000)
committerJiri Slachta <slachta@cesnet.cz>
Sat, 4 Jan 2014 13:31:35 +0000 (14:31 +0100)
spotted while looking through build-logs
only compile tested
asterisk-1.8.x uses OpenSSL instead of GnuTLS dunno about that

errors in log were:
configure: WARNING: unrecognized options:
--with-gnutls,
--without-curl,
--without-pbx-lua,
--without-gtk, --without-kde, --without-qt

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
net/asterisk-1.8.x/Makefile

index 05f949c..a1ae78b 100644 (file)
@@ -277,23 +277,20 @@ endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-chan-gtalk),)
   CONFIGURE_ARGS+= \
-       --with-gnutls="$(STAGING_DIR)/usr" \
        --with-iksemel="$(STAGING_DIR)/usr"
   SITE_VARS+= \
-       ac_cv_lib_iksemel_iks_start_sasl=yes \
-       ac_cv_lib_gnutls_gnutls_bye=yes
+       ac_cv_lib_iksemel_iks_start_sasl=yes
 else
   CONFIGURE_ARGS+= \
-       --without-gnutls \
        --without-iksemel
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-curl),)
   CONFIGURE_ARGS+= \
-       --with-curl="$(STAGING_DIR)/usr"
+       --with-libcurl="$(STAGING_DIR)/usr"
 else
   CONFIGURE_ARGS+= \
-       --without-curl
+       --without-libcurl
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-pgsql),)
@@ -342,17 +339,15 @@ ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-pbx-lua),)
   TARGET_LDFLAGS+=-ldl -lcrypt
 else
   CONFIGURE_ARGS+= \
-       --without-pbx-lua
+       --without-lua
 endif
 
 CONFIGURE_ARGS+= \
        --without-curses \
        --with-gsm=internal \
        --without-cap \
-       --without-gtk \
        --without-gtk2 \
        --without-isdnnet \
-       --without-kde \
        --without-misdn \
        --without-nbs \
        --with-ncurses="$(STAGING_DIR)/usr" \
@@ -362,7 +357,6 @@ CONFIGURE_ARGS+= \
        --without-osptk \
        --with-popt="$(STAGING_DIR)/usr" \
        --without-pri \
-       --without-qt \
        --without-radius \
        --without-sdl \
        --without-suppserv \