update openssh from 4.4p1 to 4.5p1 -- bugfixes
authorpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Mar 2007 02:17:03 +0000 (02:17 +0000)
committerpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Mar 2007 02:17:03 +0000 (02:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6493 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openssh/Makefile
net/openssh/patches/100-no_cast_fix.patch
net/openssh/patches/110-no_ripemd_fix.patch

index 5860918..6e291b4 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=4.4p1
+PKG_VERSION:=4.5p1
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
                ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
                ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
-PKG_MD5SUM:=793a709a8de695c22f523024d7e9bf07
+PKG_MD5SUM:=6468c339886f78e8a149b88f695839dd
 PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
index 9e8c4be..106b89a 100644 (file)
@@ -1,5 +1,5 @@
---- openssh-4.4p1/cipher.c.old 2006-11-25 22:56:20.000000000 +0100
-+++ openssh-4.4p1/cipher.c     2006-11-25 22:55:47.000000000 +0100
+--- /tmp/openssh-4.5p1/cipher.c        2006-08-04 21:39:39.000000000 -0500
++++ openssh-4.5p1/cipher.c     2007-03-03 20:02:45.000000000 -0600
 @@ -72,7 +72,9 @@
  
        { "3des-cbc",           SSH_CIPHER_SSH2, 8, 24, 0, EVP_des_ede3_cbc },
index f732455..c9eee8b 100644 (file)
@@ -1,5 +1,5 @@
---- openssh-4.4p1/mac.c.old    2006-11-25 22:59:32.000000000 +0100
-+++ openssh-4.4p1/mac.c        2006-11-25 22:59:48.000000000 +0100
+--- /tmp/openssh-4.5p1/mac.c   2006-09-01 00:38:37.000000000 -0500
++++ openssh-4.5p1/mac.c        2007-03-03 20:02:45.000000000 -0600
 @@ -51,8 +51,10 @@
        { "hmac-sha1-96",               EVP_sha1, 96 },
        { "hmac-md5",                   EVP_md5, 0 },