packages/ffmpeg: disable altivec support
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 Feb 2014 11:01:50 +0000 (11:01 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 Feb 2014 11:01:50 +0000 (11:01 +0000)
The altivec support in the ffmpeg package is enabled
by default which causes the following build error on
powerpc targets:

  You need a compiler that supports {} in AltiVec vector declarations.

  If you think configure made a mistake, make sure you are using the latest
  version from Git.  If the latest version fails, report the problem to the
  ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
  Include the log file "config.log" produced by configure as this will
  help solving the problem.

Altivec is not supported by any of our powerpc targets, so
disable that by default.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39445 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/ffmpeg/Makefile

index 0808f52..355410a 100644 (file)
@@ -287,6 +287,7 @@ FFMPEG_CONFIGURE:= \
        --enable-gpl \
        --enable-version3 \
        \
+       --disable-altivec \
        --disable-asm \
        --disable-doc \
        --disable-dxva2 \