batman: cleanup to match advanced version
authorpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 22:08:27 +0000 (22:08 +0000)
committerpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 22:08:27 +0000 (22:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8290 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/batman/Makefile

index b35f6e4..9c9c41c 100644 (file)
@@ -45,11 +45,10 @@ MAKE_FLAGS += \
        batmand install
 
 define Package/batman/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/batmand $(1)/usr/sbin/
-       $(CP) -a ./files/* $(1)/
-       chmod -R 755 $(1)/etc/init.d/batman
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/batmand $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/etc/init.d/batman $(1)/etc/init.d
+       $(INSTALL_DATA) ./files/etc/config/batman $(1)/etc/config
 endef
 
-
 $(eval $(call BuildPackage,batman))