update mpc to v0.15, patch by Jan Willies
authormichu <michu@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 18:55:20 +0000 (18:55 +0000)
committermichu <michu@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 18:55:20 +0000 (18:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14542 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mpc/Makefile
sound/mpc/patches/001-uclibc.patch [new file with mode: 0644]

index f6d1d68..d723ccf 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpc
-PKG_VERSION:=0.14
+PKG_VERSION:=0.15
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/musicpd
-PKG_MD5SUM:=f4218602342cf322872a41dfe0cc72e1
+PKG_MD5SUM:=48897aeb3a7ee5c64f30e56789f105a8
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/sound/mpc/patches/001-uclibc.patch b/sound/mpc/patches/001-uclibc.patch
new file mode 100644 (file)
index 0000000..298dbf2
--- /dev/null
@@ -0,0 +1,12 @@
+--- ./src/main.c.orig  2009-02-02 02:04:11.000000000 +0100
++++ ./src/main.c       2009-02-17 19:48:55.000000000 +0100
+@@ -190,7 +190,8 @@
+ static struct command *
+ find_command(const char *name)
+ {
+-      for (unsigned i = 0; mpc_table[i].command != NULL; ++i)
++      unsigned i = 0;
++      for (i = 0; mpc_table[i].command != NULL; ++i)
+               if (strcmp(name, mpc_table[i].command) == 0)
+                       return &mpc_table[i];