[package] php5: add missing dependency on libsqlite3/libpthread (#7224)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Feb 2011 22:24:39 +0000 (22:24 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Feb 2011 22:24:39 +0000 (22:24 +0000)
The binaries are already dependent on sqlite3 and pthread, not only the
corresponding php modules.

This closes #7724.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25674 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5/Makefile

index 4bb2180..8022f63 100644 (file)
@@ -54,6 +54,9 @@ define Package/php5
   ifneq ($(CONFIG_PHP5_LIBXML),)
     DEPENDS+= +libxml2
   endif
+  ifneq ($(CONFIG_PACKAGE_php5-mod-sqlite3)$(CONFIG_PACKAGE_php5-mod-pdo-sqlite),)
+    DEPENDS+= +libsqlite3 +libpthread
+  endif
 endef
 
 define Package/php5/description