added fso gsm multiplexer daemon
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Jan 2009 01:04:33 +0000 (01:04 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Jan 2009 01:04:33 +0000 (01:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14006 3c298f89-4303-0410-b956-a3cf2f4a3e73

phone/gsm0710muxd/Makefile [new file with mode: 0644]
phone/gsm0710muxd/files/gsm0710muxd.init [new file with mode: 0644]

diff --git a/phone/gsm0710muxd/Makefile b/phone/gsm0710muxd/Makefile
new file mode 100644 (file)
index 0000000..d4cfb5c
--- /dev/null
@@ -0,0 +1,64 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gsm0710muxd
+PKG_VERSION:=0.9.2.2
+PKG_REV:=95151f9e2fe37e0989b981027deefa3821a3b4e5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=git://git.freesmartphone.org/gsm0710muxd.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+include $(INCLUDE_DIR)/package.mk
+
+EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include -I$(STAGING_DIR)/usr/lib/libiconv/include
+EXTRA_LDFLAGS+=-lintl -L$(STAGING_DIR)/usr/lib/libintl/lib -liconv -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/gsm0710muxd
+  SECTION:=phone
+  CATEGORY:=Phone
+  TITLE:=GSM multiplexing daemon
+  DEPENDS:=python-core +dbus-python +python-gobject +pyserial +pyyaml +gst-python
+  URL:=http://www.freesmartphone.org
+endef
+
+define Package/gsm0710muxd/description
+  gsm0710muxd is a user space multiplexer for GSM according to the GSM 07.10 specification.
+endef
+
+define Build/Configure
+       mkdir -p $(STAGING_DIR_HOST)/usr/bin
+       ln -sf `which dbus-binding-tool` $(STAGING_DIR_HOST)/usr/bin/
+       (cd $(PKG_BUILD_DIR) && \
+               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+               $(CONFIGURE_VARS) \
+               ./autogen.sh \
+               $(CONFIGURE_ARGS_XTRA) \
+               $(CONFIGURE_ARGS) \
+       );
+endef
+
+define Build/Compile
+       DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) -C $(PKG_BUILD_DIR) install
+       rm -f $(STAGING_DIR_HOST)/usr/bin/dbus-binding-tool
+endef
+
+define Package/gsm0710muxd/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(INSTALL_BIN) ./files/gsm0710muxd.init $(1)/etc/init.d/gsm0710muxd
+endef
+
+$(eval $(call BuildPackage,gsm0710muxd))
+$(eval $(call RequireCommand,dbus-binding-tool, \
+       Command <dbus-binding-tool> not found - please install dbus-binding-tool \
+))
diff --git a/phone/gsm0710muxd/files/gsm0710muxd.init b/phone/gsm0710muxd/files/gsm0710muxd.init
new file mode 100644 (file)
index 0000000..3d42a5a
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2008 OpenWrt.org
+START=70
+
+start() {
+    /usr/sbin/gsm0710muxd -d
+}
+    
+stop() {
+    killall gsm0710muxd
+}