Do not use host includes, especially on 64-bits nomultilib systems
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Jul 2008 20:39:18 +0000 (20:39 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Jul 2008 20:39:18 +0000 (20:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11765 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/speex/Makefile
libs/speex/patches/001-remove_host_includes.patch [new file with mode: 0644]

index 6fbb108..bd64f38 100644 (file)
@@ -48,7 +48,8 @@ define Build/Configure
                --enable-fixed-point \
                --disable-oggtest \
                --disable-float-api \
-               --disable-vbr \
+               --disable-vbr, \
+               OGG_CFLAGS="" \
        )
 endef
 
diff --git a/libs/speex/patches/001-remove_host_includes.patch b/libs/speex/patches/001-remove_host_includes.patch
new file mode 100644 (file)
index 0000000..0f6ec92
--- /dev/null
@@ -0,0 +1,24 @@
+diff -urN speex-1.2beta3.2/libspeex/Makefile.am speex-1.2beta3.2.new/libspeex/Makefile.am
+--- speex-1.2beta3.2/libspeex/Makefile.am      2008-04-10 04:36:35.000000000 +0200
++++ speex-1.2beta3.2.new/libspeex/Makefile.am  2008-07-10 22:27:47.000000000 +0200
+@@ -4,7 +4,7 @@
+ EXTRA_DIST=echo_diagnostic.m
+-INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) @OGG_CFLAGS@
++INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir)
+ lib_LTLIBRARIES = libspeex.la libspeexdsp.la
+diff -urN speex-1.2beta3.2/libspeex/Makefile.in speex-1.2beta3.2.new/libspeex/Makefile.in
+--- speex-1.2beta3.2/libspeex/Makefile.in      2008-04-10 18:07:52.000000000 +0200
++++ speex-1.2beta3.2.new/libspeex/Makefile.in  2008-07-10 22:31:58.000000000 +0200
+@@ -263,7 +263,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ EXTRA_DIST = echo_diagnostic.m
+-INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) @OGG_CFLAGS@
++INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir)
+ lib_LTLIBRARIES = libspeex.la libspeexdsp.la
+ # Sources for compilation in the library