Add openssl libraries to the configure script for eap submodules (#1734)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jun 2007 17:50:21 +0000 (17:50 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jun 2007 17:50:21 +0000 (17:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7456 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/freeradius/Makefile

index 02d5bc9..6ccfe2b 100644 (file)
@@ -267,18 +267,21 @@ endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-peap),)
   PKG_CONFIGURE_ARGS+= --with-rlm_eap_peap
+  PKG_CONFIGURE_LIBS+= -lcrypto -lssl
 else
   PKG_CONFIGURE_ARGS+= --without-rlm_eap_peap
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-tls),)
   PKG_CONFIGURE_ARGS+= --with-rlm_eap_tls
+  PKG_CONFIGURE_LIBS+= -lcrypto -lssl
 else
   PKG_CONFIGURE_ARGS+= --without-rlm_eap_tls
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-ttls),)
   PKG_CONFIGURE_ARGS+= --with-rlm_eap_ttls
+  PKG_CONFIGURE_LIBS+= -lcrypto -lssl
 else
   PKG_CONFIGURE_ARGS+= --without-rlm_eap_ttls
 endif