libptmalloc3: override CFLAGS correctly
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:02 +0000 (00:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:02 +0000 (00:57 +0000)
SYS_CFLAGS has no effect for our build targets, OPT_CFLAGS is what we intended
to use.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39810 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libptmalloc3/Makefile

index a591c7e..81f6174 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libptmalloc3
 PKG_VERSION:=20060531
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_BUILD_DIR:=$(BUILD_DIR)/ptmalloc3
 
 PKG_SOURCE:=ptmalloc3-current.tar.gz
@@ -32,7 +32,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               SYS_FLAGS="$(TARGET_CFLAGS)" \
+               OPT_FLAGS="$(TARGET_CFLAGS)" \
                linux-shared-nothreads
 endef