don't generate a certificate during stunnel build - will make a default one later
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Nov 2006 15:12:59 +0000 (15:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Nov 2006 15:12:59 +0000 (15:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5604 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/stunnel/Makefile

index c2a34e1..78479eb 100644 (file)
@@ -34,6 +34,8 @@ define Build/Configure
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
+       mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel
+       echo '#dummy' > $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
@@ -44,7 +46,6 @@ define Package/stunnel/install
        install -d -m0755 $(1)/etc/stunnel $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/stunnel $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstunnel.so $(1)/usr/sbin/
        install -d -m0755 $(1)/etc/stunnel $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/stunnel $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstunnel.so $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem $(1)/etc/stunnel/
        $(CP) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
        $(CP) ./files/stunnel.init $(1)/etc/init.d/S90stunnel
 endef
        $(CP) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
        $(CP) ./files/stunnel.init $(1)/etc/init.d/S90stunnel
 endef