remove libusb-legacy and point its users at libusb-compat
[packages.git] / utils / sane-backends / Makefile
index 01aa4d5..5a99780 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.20
+PKG_VERSION:=1.0.23
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
-PKG_MD5SUM:=a0cfdfdebca2feb4f2ba5d3418b15a42
+PKG_SOURCE_URL:=http://fossies.org/linux/misc \
+       ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION) \
+       https://alioth.debian.org/frs/download.php/3503
+PKG_MD5SUM:=e226a89c54173efea80e91e9a5eb6573
 
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -32,7 +35,7 @@ define Package/sane-backends
 $(call Package/sane-backends/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+sane-libs +libtiff
+  DEPENDS:=+sane-libs
   TITLE+= (backends)
 endef
 
@@ -45,7 +48,7 @@ define Package/sane-libs
   $(call Package/sane-backends/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libjpeg +libpthread +libusb
+  DEPENDS:=+libjpeg +libtiff +libusb-compat +libv4l +cups
   TITLE+= (libraries)
 endef
 
@@ -75,8 +78,10 @@ CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --disable-translations \
+       --disable-latex \
        --without-gphoto2 \
        --disable-debug \
+       --without-snmp
 
 define Build/Configure
        mkdir -p $(PKG_BUILD_DIR)/backend/.libs