cryptsetup: moved to github
[packages.git] / utils / sane-backends / Makefile
index 177ff12..418a468 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.20
+PKG_VERSION:=1.0.24
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
-PKG_MD5SUM:=a0cfdfdebca2feb4f2ba5d3418b15a42
+PKG_SOURCE_URL:=http://fossies.org/linux/misc \
+       https://alioth.debian.org/frs/download.php/3958
+PKG_MD5SUM:=1ca68e536cd7c1852322822f5f6ac3a4
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=aclocal.m4
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,7 +36,7 @@ define Package/sane-backends
 $(call Package/sane-backends/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+sane-libs +libtiff
+  DEPENDS:=+sane-libs
   TITLE+= (backends)
 endef
 
@@ -43,7 +49,7 @@ define Package/sane-libs
   $(call Package/sane-backends/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libjpeg +libpthread +libusb
+  DEPENDS:=+libjpeg +libtiff +libusb-compat +libv4l +cups
   TITLE+= (libraries)
 endef
 
@@ -73,20 +79,16 @@ CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --disable-translations \
+       --disable-latex \
        --without-gphoto2 \
        --disable-debug \
+       --without-snmp
 
 define Build/Configure
        mkdir -p $(PKG_BUILD_DIR)/backend/.libs
        $(Build/Configure/Default)
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/sane-backends/conffiles
 /etc/sane.d/saned.conf
 endef
@@ -111,9 +113,9 @@ define Package/sane-frontends/install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sane $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsane.{a,so*} $(1)/usr/lib/
 endef