lxc: moved to github
[packages.git] / utils / petitboot / Makefile
index 9022c1f..4ae52e8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=petitboot
-PKG_VERSION:=93b2c2e0f0ca46d2a823b33cdfa44d082e9e8d10
+PKG_REV:=93b2c2e0f0ca46d2a823b33cdfa44d082e9e8d10
+PKG_VERSION:=20090709
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://ozlabs.org/home/jk/git/petitboot
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
 
 PKG_INSTALL=1
 
@@ -26,8 +27,8 @@ define Package/petitboot
        CATEGORY:=Boot Loaders
        TITLE:=A kexec based bootloader
        URL:=http://ozlabs.org/~jk/projects/petitboot/
-       MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
-       DEPENDS:=+kexec-tools +libncurses +libtwin +udev +ps3-utils
+       MAINTAINER:=Geoff Levand <geoff@infradead.org>
+       DEPENDS:=@TARGET_ps3 +kexec-tools +libncurses +libtwin +udev +ps3-utils
 endef
 
 define Package/petitboot/description
@@ -71,7 +72,7 @@ petitboot-install-autorun-$(CONFIG_PETITBOOT_AUTORUN_GUI) = \
        ln -sf pb-twin $(1)/usr/sbin/petitboot
 
 CONFIGURE_ARGS += $(petitboot-config-args-y) \
-       PACKAGE_VERSION=$(shell echo ${HOSTNAME})-$(shell date +%y.%m.%d-%H.%M)
+       PACKAGE_VERSION=$(shell uname -n)-$(shell date +%y.%m.%d-%H.%M)
 
 EXTRA_CPPFLAGS += $(petitboot-cppflags-y)