remove libusb-legacy and point its users at libusb-compat
[packages.git] / utils / owfs / Makefile
index 2e58418..b35eec6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=owfs
-PKG_VERSION:=2.7p21
-PKG_RELEASE:=2
+PKG_VERSION:=2.8p13
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=8aea6f3bb0dc9fdb52ed3f0e9d84fa79
+PKG_MD5SUM:=cc3e2542aed41c753bffca13f2a0a84e
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -33,18 +33,18 @@ define Package/$(PKG_NAME)/Default
 endef
 
 define Package/$(PKG_NAME)/Default/description
-  OWFS is a suite of programs that designed to make the 1-wire bus and its 
-  devices easily accessible. The underlying priciple is to create a virtual 
-  filesystem, with the unique ID being the directory, and the individual 
-  properties of the device are represented as simple files that can be read 
+  OWFS is a suite of programs that designed to make the 1-wire bus and its
+  devices easily accessible. The underlying priciple is to create a virtual
+  filesystem, with the unique ID being the directory, and the individual
+  properties of the device are represented as simple files that can be read
   and written.
 
-  Details of the individual slave or master design are hidden behind a 
-  consistent interface. The goal is to provide an easy set of tools for a 
-  software designer to create monitoring or control applications. There are 
-  some performance enhancements in the implementation, including data caching, 
-  parallel access to bus masters, and aggregation of device communication. 
-  Still the fundemental goal has been ease of use, flexibility and correctness 
+  Details of the individual slave or master design are hidden behind a
+  consistent interface. The goal is to provide an easy set of tools for a
+  software designer to create monitoring or control applications. There are
+  some performance enhancements in the implementation, including data caching,
+  parallel access to bus masters, and aggregation of device communication.
+  Still the fundemental goal has been ease of use, flexibility and correctness
   rather than speed.
 endef
 
@@ -72,13 +72,13 @@ endef
 
 define Package/libow
   $(call Package/owfs/Library)
-  DEPENDS:=+libusb +libpthread
+  DEPENDS:=+libusb-compat +libpthread
   TITLE:=OWFS - common shared library
 endef
 
 define Package/libow/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS library.
 endef
 
@@ -90,7 +90,7 @@ endef
 
 define Package/libow-capi/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS C-API library.
 endef
 
@@ -101,11 +101,12 @@ endef
 define Package/owshell
   $(call Package/owfs/Utility)
   TITLE:=OWFS - shell utilities
+  DEPENDS+= +USE_UCLIBC:librpc
 endef
 
 define Package/owshell/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS shell utilities.
 endef
 
@@ -118,7 +119,7 @@ endef
 
 define Package/owfs/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS fuse filesystem.
 endef
 
@@ -133,7 +134,7 @@ endef
 
 define Package/owhttpd/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS http server.
 endef
 
@@ -144,7 +145,7 @@ endef
 
 define Package/owftpd/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS ftp server.
 endef
 
@@ -155,7 +156,7 @@ endef
 
 define Package/owserver/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS network server.
 endef
 
@@ -167,16 +168,12 @@ CONFIGURE_ARGS += \
        --with-fuseinclude="$(STAGING_DIR)/usr/include" \
        --with-fuselib="$(STAGING_DIR)/usr/lib" \
        --enable-shared \
-       --disable-rpath \
        --enable-zero \
        --disable-parport \
-       --disable-ownfsd \
        --disable-ownet \
        --disable-owpython \
-       --disable-libow-perl \
        --disable-owphp \
        --disable-owtcl \
-       --disable-owside \
        --disable-swig \
 
 CONFIGURE_VARS += \
@@ -185,16 +182,15 @@ CONFIGURE_VARS += \
        lt_cv_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
        shrext_cmds=".so" \
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); ./bootstrap)
-       $(call Build/Configure/Default)
-endef
+MAKE_FLAGS += \
+       CC="$(TARGET_CC)" \
+       HOST_CPU="$(PKGARCH)"
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR)/usr/include
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/ow{capi,fs_config}.h $(STAGING_DIR)/usr/include/
        $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow{,capi}*.{a,so*} $(STAGING_DIR)/usr/lib/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow{,capi}*.so* $(STAGING_DIR)/usr/lib/
 endef
 
 define Package/owfs/install