restorefactory: move to github (obsolete)
[packages.git] / utils / heyu / Makefile
index b451d79..6694a26 100644 (file)
@@ -1,20 +1,19 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=heyu
-PKG_VERSION:=2.0beta.5
+PKG_VERSION:=2.9.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://heyu.tanj.com/download/
-PKG_SOURCE:=heyu-$(PKG_VERSION).tgz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
+PKG_MD5SUM:=89d20d7f45109e7add5f0a141eac04eb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,23 +22,37 @@ define Package/heyu
   CATEGORY:=Utilities
   DEPENDS:=+setserial
   TITLE:=X10 home automation control using a CM11A
-  DESCRIPTION:=10 home automation control using the CM11A serial device.
   URL:=http://heyu.tanj.com/heyu2/
 endef
 
+define Package/heyu/description
+       HEYU is a text-based console program for remotely controlling lights
+       and appliances in the home or office.   It is made available under a
+       free and open source license.
+
+       Heyu uses the CM11A computer interface to send and receive X10 control
+       signals over the AC power lines to modules which can turn On, Off, or
+       Dim attached lamps or appliances.   It can store a schedule of timed
+       events in the CM11A memory for execution when the computer is turned
+       off or disconnected.
+endef
+
 define Package/heyu/conffiles
 /etc/heyu/x10.conf
 endef
 
 define Build/Compile
-  $(call Build/Compile/Default, CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ")
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) \$$$$(DFLAGS)" \
+       )
 endef
 
-define Package/heyu/install    
-       install -d -m0755 $(1)/etc/$(PKG_NAME)
-       install -m0644 ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
-       install -d -m0755 $(1)/usr/bin
-       install -m0644 $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+define Package/heyu/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+       $(INSTALL_DATA) ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
 endef
 
 $(eval $(call BuildPackage,heyu))