restorefactory: move to github (obsolete)
[packages.git] / utils / heyu / Makefile
index 3b15026..6694a26 100644 (file)
@@ -1,23 +1,19 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=heyu
-PKG_VERSION:=2.0beta.5
+PKG_VERSION:=2.9.1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=heyu-$(PKG_VERSION).tgz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://heyu.tanj.com/download/
-PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=89d20d7f45109e7add5f0a141eac04eb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,6 +25,18 @@ define Package/heyu
   URL:=http://heyu.tanj.com/heyu2/
 endef
 
+define Package/heyu/description
+       HEYU is a text-based console program for remotely controlling lights
+       and appliances in the home or office.   It is made available under a
+       free and open source license.
+
+       Heyu uses the CM11A computer interface to send and receive X10 control
+       signals over the AC power lines to modules which can turn On, Off, or
+       Dim attached lamps or appliances.   It can store a schedule of timed
+       events in the CM11A memory for execution when the computer is turned
+       off or disconnected.
+endef
+
 define Package/heyu/conffiles
 /etc/heyu/x10.conf
 endef
@@ -39,9 +47,10 @@ define Build/Compile
        )
 endef
 
-define Package/heyu/install    
+define Package/heyu/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+
        $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
        $(INSTALL_DATA) ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
 endef