remove libusb-legacy and point its users at libusb-compat
[packages.git] / utils / flashrom / Makefile
index 6d8b5a7..89ce6ca 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,15 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flashrom
-PKG_VERSION:=0.9.3
+PKG_VERSION:=0.9.4
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://qa.coreboot.org/releases/
-PKG_MD5SUM:=eccdec2764223f5d2839bf577380eaa9
+PKG_SOURCE_URL:=http://download.flashrom.org/releases
+PKG_MD5SUM:=d739a91aece12cc1e622038bb199541c
 
-include $(INCLUDE_DIR)/package.mk
+PKG_INSTALL:=1
 
+include $(INCLUDE_DIR)/package.mk
 
 define Package/flashrom
   SECTION:=utils
@@ -24,18 +25,21 @@ define Package/flashrom
   TITLE:=FlashROM Utility
   URL:=http://www.flashrom.org/
 # XXX: needs <sys/io.h>, only available on these arch right now
-  DEPENDS:=+zlib +pciutils +dmidecode @(arm||armeb||i386||i686||x86_64)
+  DEPENDS:=+zlib +pciutils +dmidecode +libftdi +libusb-compat @(arm||armeb||i386||i686||x86_64)
 endef
 
 define Package/flashrom/description
  flashrom is a utility for identifying, reading, writing, verifying
  and erasing flash chips. It's often used to flash BIOS/EFI/coreboot
- /firmware images. 
+ /firmware images.
 endef
 
+MAKE_FLAGS += \
+       PREFIX="/usr"
+
 define Package/flashrom/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/flashrom $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/flashrom $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,flashrom))