zip: move to github
[packages.git] / utils / dtach / Makefile
index e9894bd..5d01d28 100644 (file)
@@ -1,22 +1,19 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dtach
-PKG_VERSION:=0.6
+PKG_VERSION:=0.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/dtach
-PKG_MD5SUM:=13d5b834a7855f2448dbf33e0d3d3af8
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=ec5999f3b6bb67da19754fcb2e5221f3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,17 +24,25 @@ define Package/dtach
   URL:=http://dtach.sourceforge.net/
 endef
 
-define Build/Configure 
+define Package/dtach/description
+       dtach is a tiny program that emulates the detach feature of screen,
+       allowing you to run a program in an environment that is protected from
+       the controlling terminal and attach to it later. dtach does not keep
+       track of the contents of the screen, and thus works best with programs
+       that know how to redraw themselves.
+endef
+
+define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)
 endef
 
-define Package/dtach/install   
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/dtach $(1)/usr/bin/
+define Package/dtach/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dtach $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,dtach))